ArmA 2 – FDF Mod features

Requirements

Working installation of ArmA 2 and Operation Arrowhead expansion or ArmA 2:Combined Operations. Patch 1.54 or greater recommended.

Download mirrors (611 MB):

(MD5 checksum 28405daaba9ad27c1ad7aabb6027ffe9)

help-browser Installation instructions for FDF Mod 1.0 (retail version)
Installation instructions for FDF Mod 1.0 (Steam version)

While you are downloading you can take a look at our release trailer

28 December 2010 | 25 Comments

FDF Maneuvers

Following severe internal clashes on Podagorsk Finnish Defence Forces holds maneuvers for possible deployment to the conflict zone. Media has speculated that the deployment likely takes place “in the near future” and should that occur the FDF troops will operate under the NATO-led coalition with UN mandate.

The latest incarnation of FDFmod will require up to date version of both ARMA 2 and Operation Arrowhead.

Finnish Helicopter Battalion trains personnel needed to maintain flight readiness, to perform service flights for FDF and to give assistance to different authorities. Since 1962 all FDF helicopters are based at Utti Air Base and are part of army aviation.

FDF_Podagorsk_news_1

We are proud to present an update to our first release for ArmA II: FDF Podagorsk 1.1

Version history

1.1

1.0

FDF Podagorsk requires a working installation of ArmA II: Version 1.0 or higher.

To install it, just extract FDF_Podagorsk_v11.rar to your ArmA 2\Addons directory or use modfolders.

Download mirrors (159 MB):

(MD5 checksum DFD8848F2857DAD2B133BB5C92AFEE29 | Key for servers: FDF.bikey)

More articles in the archives »